external DC maintenance caused outage

Incident Report for Bluefin - Till Payments

Resolved

This incident has been resolved.
Posted Apr 29, 2026 - 04:47 UTC

Investigating

We are currently investigating this issue.
Posted Apr 28, 2026 - 18:23 UTC
This incident affected: Tillpayments – AU, GB, IE, UAE and Tillpayments – USA.