Possible Interruption

Incident Report for Bluefin - Till Payments

Resolved

Service has been fully restored. Thank you for your patience.
Posted Jun 15, 2026 - 09:46 UTC

Update

We are continuing to monitor the results of the fix, we apologize for the inconvenience and we thank you for your patience.
Posted Jun 15, 2026 - 09:00 UTC

Update

We are continuing to monitor the results of the fix, we apologize for the inconvenience and we thank you for your patience.
Posted Jun 15, 2026 - 07:40 UTC

Update

We are continuing to monitor the results of the fix, we apologize for the inconvenience and we thank you for your patience.
Posted Jun 15, 2026 - 06:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2026 - 06:30 UTC

Investigating

We are investigating a possible interruption in transaction processing. We appreciate your patience. Thank you.
Posted Jun 15, 2026 - 06:19 UTC
This incident affected: Tillpayments – AU, GB, IE, UAE.